PE1


hostname PE1
mpls ldp router-id Loopback0 force
!
ip vrf custa
rd 1400:1
route-target export 1400:1
route-target import 1400:1
!
ip vrf custd
rd 1400:2
export map EXPORT_MAP
route-target export 1400:2
route-target import 1400:2
route-target import 1400:3
!
ip cef
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 201.130.22.1 255.255.255.255

interface Ethernet0/0
ip address 172.16.10.1 255.255.255.252
mpls ip
!
interface Ethernet0/1
ip address 192.168.0.1 255.255.255.252
!
interface Ethernet0/1.401
encapsulation dot1Q 401
ip vrf forwarding custa
ip address 192.168.101.1 255.255.255.0
!
interface Ethernet0/1.402
encapsulation dot1Q 402
xconnect 4.4.4.4 10 encapsulation mpls
!
interface Ethernet0/1.403
encapsulation dot1Q 403
ip address 203.142.82.1 255.255.255.252
!
interface Ethernet0/1.404
description CUST-D-SITE1
encapsulation dot1Q 404
ip vrf forwarding custd
ip address 192.168.103.1 255.255.255.0
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
router ospf 101 vrf custa
redistribute bgp 1400 subnets
network 192.168.101.0 0.0.0.255 area 0
!
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
network 172.16.10.0 0.0.0.3 area 0
!
router rip
!
address-family ipv4 vrf custd
redistribute bgp 1400 metric 10
network 192.168.103.0
no auto-summary
exit-address-family
!
router bgp 1400
bgp log-neighbor-changes
network 201.130.22.1 mask 255.255.255.255
neighbor 4.4.4.4 remote-as 1400
neighbor 4.4.4.4 update-source Loopback0
neighbor 203.142.82.2 remote-as 1401
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf custa
redistribute ospf 101
exit-address-family
!
address-family ipv4 vrf custd
redistribute rip metric 10
exit-address-family
!
ip prefix-list EXPORT_LIST seq 10 permit 15.0.0.0/8
!
route-map EXPORT_MAP permit 10
match ip address prefix-list EXPORT_LIST
set extcommunity rt 1400:4 additive

PE2

hostname PE2
mpls ldp router-id Loopback0 force
!
ip vrf custa
rd 1400:1
export map EXPORT_MAP
route-target export 1400:1
route-target import 1400:1
route-target import 1400:4
!
ip vrf custd
rd 1400:2
route-target export 1400:2
route-target import 1400:2
!
ip cef
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip ospf network point-to-point
!
interface Ethernet0/0
ip address 172.16.10.10 255.255.255.252
mpls ip
!
interface Ethernet0/1
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/1.401
encapsulation dot1Q 401
ip vrf forwarding custa
ip address 192.168.102.1 255.255.255.0
!
interface Ethernet0/1.402
encapsulation dot1Q 402
xconnect 1.1.1.1 10 encapsulation mpls
!
interface Ethernet0/1.404
encapsulation dot1Q 404
ip vrf forwarding custd
ip address 192.168.104.1 255.255.255.0
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
!
router eigrp 100
!
address-family ipv4 vrf custa autonomous-system 1
redistribute bgp 1400 metric 10000 1 255 1 1400
redistribute static metric 1000 1 255 10 1400
network 192.168.102.0
exit-address-family
!
router ospf 404 vrf custd
redistribute bgp 1400 subnets
network 192.168.104.0 0.0.0.255 area 0
!
router ospf 1
redistribute static subnets
network 4.4.4.4 0.0.0.0 area 0
network 172.16.10.8 0.0.0.3 area 0
!
router bgp 1400
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1400
neighbor 1.1.1.1 update-source Loopback0
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf custa
redistribute eigrp 1
exit-address-family
!
address-family ipv4 vrf custd
redistribute ospf 404
exit-address-family
!
ip route 11.11.11.20 255.255.255.255 Ethernet0/1.401 192.168.102.2
ip route vrf custa 172.16.10.8 255.255.255.252 Ethernet0/0 172.16.10.9
!
ip prefix-list EXPORT_LIST seq 5 permit 11.11.11.4/32
!
route-map EXPORT_MAP permit 10
match ip address prefix-list EXPORT_LIST
set extcommunity rt 1400:3 additive
!

Responses

Your email address will not be published. Required fields are marked *

+