MPLS Traffic Engineering merupakan teknik yang memungkinkan router MPLS melakukan unequal load balancing, ini sangat berguna untuk efisiensi bandwidth, lanjut lihat gambar

Misalkan dari Network A mau menuju Network C untuk membawa traffic sebesar 15G, terdapat beberapa path,

  1. Path pertama Ra-R1-R4-R8-Rc
  2. Path kedua Ra-R1-R2-R5-R7-R8-Rc

Kita asumsikan path pertama jalur R1 ke R4 adalah 2x10G, dan path kedua yaitu R1 ke R2 adalah 1x10G. Path kedua jika kondisi normal dijadikan backup link dengan status idle alias gak dipake sama skali. Di suatu ketika link R1 ke R4 memiliki kendala sehingga menyebabkan 1 link nya tidak bisa digunakan yang awalnya kapasitasnya adalah 2x10G menjadi 10G. Dengan adalanya MPLS Traffic engineering ini kita bisa melakukan unequal cost load balancing, yang memungkinkan kita membuat jalur-jalur untuk membagi dan melewatkan traffic. kita bisa membagi 8G melewati Path pertama dan 7G melewati Path kedua sehingga trafic sebesar 15G tetap bisa dilewatkan menuju Network C

MPLS Traffic Enginnering ini menggunakan protocol RSVP (Resource Reservation Protocol) untuk secara otomatis memaintain tunnel dan memastikan tunnel tersebut dalam keadaan baik. Tunnel inilah yang dilewatkan traffic yang sebelumnya dipisah-pisah

RSVP ini dijalankan pada setiap router MPLS dan saling di distribusikan ke router MPLS lain melalui IGP misalnya OSPF/IS-IS. Eigrp tidak bisa, sementara ini yang support Traffic engineering hanyalah IGP berbasis link-state

Konfigurasi:

Pertama kita buat dulu loopback baru yang akan dijadikan path untuk TE (traffic engineering ini) kita pakai loopback 10

Router(config)#interface Loopback 10
Router(config-if)#ip address 10.11.11.11 255.255.255.255
!
Router(config)#ip cef
Router(config)#mpls traffic-eng tunnels

Konfigurasikan interface yang bersangkutan agar menjalan RSVP signaling dan IGP Flooding

Router(config-if)#mpls traffic-eng tunnels
Router(config-if)#ip rsvp bandwidth [xkbps]-[ykbps]

Ketiga blok konfig diatas wajib diaplikasikan disemua node MPLS yang akan melakukan traffic engineering. x dan y bersifat opsional, misalkan kita menentukan nilai dari bandwith dalam Kbps di interface yang akan di alokasikan. range nya adalah 1 ke 10.000.000

x = merupakan alokasi maksimal bandwidth (default nya adlah 75% dari bandwidth yang tersedia)
y = merupakan alokasi maksimal bandwidth untuk satu LSP (default nya adalah 100% dari bandwidth yang tersedia

MPLS Traffic engineering tunnel bersifat unidirectional (searah) dan di config pada router untuk membuat LSP headend (kepala) yang akan menuju tailend (ekornya). untuk pembuatan tunnel ini kita hanya config di ujung ke ujung dimana akan dilewati traffic traffic engineering ini.

Router(config)#interface Tunnel0

Konfigurasi headend untuk menggunakan IP loopback

Router(config-if)#ip unnumbered Loopback0

Tentukan mode tunnel menjadi mode MPLS traffic engineering, pilihan lain bisa menggunakan encaptulation GRE dan IPsec, namun tentu kali ini kita menggunakan mpls traffic-eng

Router(config-if)#tunnel mode mpls traffic-eng

Berikutnya adalah destinasi IP tujuan, atau yang disebut tail-end router. jadi ada headend dan juga ada tail-en, dari kepala ke ekor. hehe. misalnya tail-end tujuannya adalah 10.11.11.15. jadi kita akan membuat tunnel dari 10.11.11.11 ke 10.11.11.15

Router(config-if)#tunnel destination 10.11.11.15

Berikutnya menentukan metode kalkulasi yang akan digunakan oleh path tunnel tadi. tunnel memiliki dua opsi untuk metodenya yaitu preferred explicit path dan backup dynamic path. perintah ini mengkonfigurasi tunnel untuk menggunakan IP expicit path atau dynamically path yang di kalkulasi dari database topologi traffic enginnering. Dynamic path akan digunakan jika explicit path tidak disediakan

Router(config-if)# tunnel mpls traffic-eng path-option {dynamic | explicit {nama-path-yg-diinginkan | nomorpath }} [lockdown]

Konfigurasi Explicit Path :

Router(config)#interface Tunnel0
Router(config-if)#tunnel mpls traffic-eng path-option explicit {id|nama}

Konfigurasi Dynamic path:
Backup dynamic path ini di kalkulasi secara otomatis dari basis topologi traffic engineering

Router(config-if)tunnel mpls traffic-eng path-option dynamic

Untuk explicit path, kita harus setup manual pathnya, kita harus membuat secara manual entri pathnya. setiap entrinya mengindikasikan hop ke arah destinasinya. setiap hop di kenali dari RID (router id nya) atau alamat next-hop interface dari router next-hop

Untuk masuk ke subcommand untuk IP explicit path ini menggunakan perintah ip explicit-path. IP explicit path ini berisi list IP address yang setiap entrinya merepresentasikan node atau link dari explicit path.

Router(config)# ip explicit-path {name WORD | identifier number } [{enable | disable}]
Router(cfg-ip-expl-path)#next-address
Router(cfg-ip-expl-path)#next-address
. . .
Router(cfg-ip-expl-path)#next-address
Router(cfg-ip-expl-path)#exit

setelah traffic enginering path telah selesai dibuat langkah selanjutnya adalah men konfigurasi router OSPF untuk menjalankan traffic enginnering ini. kita saat ini pakai OSPF dulu aja ya, karena saya rasa IS-IS sudah sangat jarang digunakan. umumnya ISP menggunakan OSPF untuk backbone MPLS nya

Langkah pertama adalah masuk ke ospfnya n

Router(config)#router ospf

Kemudian konfigurasikan OSPF untuk kebutuhan MPLS traffic enggineering untuk area yang mana

Router(config-router)#mpls traffic-eng area area

Konfigurasikan RID menggunakan IP loopback

Router(config-router)#mpls traffic-eng area router-id loop0

 — Mengkonfigurasi MPLS Tunnel Unequal-Cost Load Balancing–

Unequal-cost load balancing bisa di konfigurasikan atara dua atau lebih tunnel MPLS traffic engineering dengan destinasi tail end yang sama. Parameter bandidth digunakan untuk load balancing menggunakan kbps. default nya adalah 0

Router(config)#interface Tunnel0
Router(config-if)#tunnel destination
Router(config-if)#tunnel mpls traffic-eng bandwidth x
Router(config)#interface Tunnel1
Router(config-if)#tunnel destination
Router(config-if)#tunnel mpls traffic-eng bandwidth y

Verifikasi MPLS Traffic engineering

show mpls traffic-eng tunnel [tunnel_interface | destination address |
source-id { ip-address | 0-MAX | name name role

~

Responses

Your email address will not be published. Required fields are marked *

+